www.testfreaks.com

Reviews, reviews, reviews...

Gigabyte-ga-z77x-up4-th.33888007
8.9 out of 10

Gigabyte GA-Z77X-UP4-TH

Great Deal: $41.00

Reviews and Problems with Gigabyte GA-Z77X-UP4-TH

Showing 1-5 of 5
Overall 2
2.0

Disappointed

Terrence Alexander, Amazon
31 August 2014
  • Summary: Had too many bad experiences with this board. When I try to power on my machine, it powers on briefly for 1 second then cuts off. If I press the power button on the tower again nothing happen until I switch off the power supply and switch it back on. It would then briefly power on and then cut off again. Tried everything possible but no luck.
  • Read full review
Overall 2
2.0

Third motherboard...it simply does not boot

ejsl, Amazon
17 May 2013
  • Summary: Be careful when buying this, I am on my third board and keep getting power errors. I know this is not the case for I have tried in multiple power supplies (AX 750, and HX 650). All the personal on support hardly speaks any english.
  • Read full review
Overall 2
2.0

Giga-butt...this board stinks.

El Pato, Amazon
18 April 2013
  • Summary: I have long loved Gigabyte boards and have happily recommended them to friends and clients over the years so when it came time for me to build my updated Ivy Bridge Core i7 computer, I immediately looked for a Gigabyte board. This board fit into my price range and seemed like it would be a good fit for my needs so I purchased it and waited for all my parts to arrive so that I could start my build.
  • Read full review
Overall 2
2.0

Crushing Disapointment

jason west, Amazon
23 November 2012
  • Summary: Brought this Motherboard based on the great reviews. Built the pc, and no power. After Hours of troubleshooting, determined it was the mother board. Tried to contact Gigabyte, for support, and after 48 hours, gave up and returned it.
  • Read full review
Overall 2
2.0

dead

Mr. I. Simpson, Amazon
17 March 2013
  • Summary: Built my pc with this motherboard,switched on and the Motherboard was dead.Checked for shorts and made sure all cables were connected properly.Checked cpu was seated correctly.Changed power supply unit with one that I know works.I've built about 12 computers previously and its the first time this has happened to me.Sent board back to Amazon and they quickly refunded me.I bought an Asus motherboard instead and when I rebuilt the PC it worked first time.
  • Read full review