www.testfreaks.com

Reviews, reviews, reviews...

Gigabyte-g1-sniper-3.33337416
9.4 out of 10

Gigabyte G1.Sniper 3

GIGABYTE G1.Sniper 3 Gaming Motherboard - The G1.Sniper 3 is t Read more

Best Price at Amazon

Reviews and Problems with Gigabyte G1.Sniper 3

Showing 1-4 of 4
Overall 6
6.0

Faulty Sound

Andrew G., Newegg
27 February 2014
  • Pros: When I first got this board I was really impressed. It was easy to install every piece of hardware. Drivers worked great, what more could I want?
  • Cons: I had wanted a mobo that would last, unfortunately this was not the case. After about two months, the sound would go full blast and become distorted. Ignoring my system volume settings. The only way to solve this issue was to restart my system. I tried reinstalling the drivers but that only proved to fix this issue for a few days. As I researched the matter, it seems it has been an issue for this board on more then just a few occasions. Having a difficult time to get ...
  • Read full review
Overall 6
6.0

It's okay.

Justin F., Newegg
10 February 2014
  • Pros: Looks good, easy to install
  • Cons: Every couple of reboots, the BIOS will rearrange my Boot order and act as though I have no bootable disk drives connected to my system. Also, every time I go to reboot it, it likes to cycle through about 3 or 4 reboots before it will allow me to even select a boot device if I have too or boot straight into windows.
  • Read full review
Overall 6
6.0

Failed in less than a year, RMA process is not the speediest.

DJD, Amazon
6 December 2013
  • Summary: Failed after 8 months - would not POST. From the day you request an online RMA from gigabyte to the day you get back a repaired/refurbished unit is about 2 weeks. If you cannot afford to be out of your PC for 2 weeks, you may want to consider this.
  • Read full review
Overall 6
6.0

Onboard sound device fails

Mo, Amazon
3 weeks ago
  • Summary: I have a new G1 Sniper 3 that I have been using for a few days. I seem to be experiencing an issue where the onboard sound device fails to be enabled on boot up (even though I verified it is set to enabled in bios).
  • Read full review