www.testfreaks.com

Reviews, reviews, reviews...

Question: I inserted the software and it seems like it works, then i plugg

I inserted the software and it seems like it works, then i plugged in the cable in the usb drive, it does read it and i can see it in "my computer" the problem is that when i click it, it says it needs to format it before i can start using it, so i format it, then it gives me an error message that it was unable to format.. this is the only problem i have, i already selected "usb update" and everything but the formatting part is the main issue..

  • Re: I inserted the software and it seems like it works, then i plugg

    how did u solve this problem, because I have exactly the same problem, cannot format the divice

    Best answer
    Helpful
    Not helpful
    Report this user
    0 users are satisfied with this answer
  • Re: I inserted the software and it seems like it works, then i plugg

    Try to install drivers for it or get a firmware update.

    Best answer
    Helpful
    Not helpful
    Report this user
    0 users are satisfied with this answer
  • Re: I inserted the software and it seems like it works, then i plugg

    i have exactly the same problem! is there no solution to that?

    Best answer
    Helpful
    Not helpful
    Report this user
    0 users are satisfied with this answer
  • Re: I inserted the software and it seems like it works, then i plugg

    have u found the answer anywhere else??

    Best answer
    Helpful
    Not helpful
    Report this user
    0 users are satisfied with this answer