www.testfreaks.com

Reviews, reviews, reviews...

Profile-400sx.32567619
3.6 out of 10

Profile 400sx

Best Price at Amazon

Reviews and Problems with Profile 400sx

Showing 1-5 of 5
Overall 10
10
Value for money 10
10

User Review

finbar, Car Review
16 February 2011
  • Summary: This review is for the 400SX, NOT the 800SX other reviewers have included under the 400SX heading!
  • Read full review
Overall 10
10
Value for money 10
10

User Review

Patrick, Car Review
26 February 2003
  • Summary: I have the 400msx which is just a mono version of the 400sx. I have this wire up to 2 MA Audio subs wired for a 2 0hm load and crossed over @ 80hertz w/ 7-8 db of bass boost. This thing makes those subs pound harder then any amp I've had this these subs hooked up to. I'm using the stock headunit hooked up to the high inputs so I haven't found out it's true potential yet.
  • Read full review
Overall 8
8.0
Value for money 10
10

User Review

notorious jlf, Car Review
31 December 2002
  • Summary: not a bad amp, i got it powering two audiobahns and it gets really loud, it does dim headlights and neon lights but it throws out good power for the price! if running subs bridging this amp is the best way to go alotta power,probably puts out around 300w peak to each of my subs pretty good amp, cheak out my amp and install,@ http://www.sounddomain.com/member_pages/view_page.pl?
  • Read full review
Overall 10
10
Value for money 10
10

User Review

Casey Worth, Car Review
25 October 2002
  • Summary: Just wired up my 800sx with three MTX thunder 6000's. What a bang!!!!!! Great amp pushing 600 watts to my three tens wired in parallel for a 4 ohm impedance. With the gain at 1/4 my Impala became a high powered vibrator. Great look, great price, and even better preformance.
  • Read full review
Overall 4
4.0
Value for money 2
2.0

User Review

jim winters, Car Review
24 July 2002
  • Summary: overall this is a really cool little amp if your going to run a set of 6x9's or some door speakers.but when i tried to run my 2-jbl 1041's(10")it had problems....when wired standard it had no "push" and it dimmed the headlights(even though it is wired directly to the battery.when in briged mode and wired "in series" with the gain at almost 3/4's it kicked goooood!and the headlights didn't dim anymore. but when pushed hard it runs red hot! and shuts down in @20 minutes.
  • Read full review