www.testfreaks.com

Reviews, reviews, reviews...

Onkyo-tx-nr609.32590952
7.9 out of 10

Onkyo TX-NR609

Targeting the sweet spot where affordability meets superb functi Read more

Best Price at Amazon

Reviews and Problems with Onkyo TX-NR609

Showing 1-10 of 18
Overall 2
2.0

No Sound After Two Years

Mark E. Mayo "Cycle Newbie", Amazon
2 weeks ago
  • Summary: Well, after 25 months, my sound went out just like the others. I have ordered the following capacitors to replace them myself for the HDMI board. This isn't acceptable and I won't be purchasing another Onkyo product anytime soon. http://www.amazon.com/gp/product/B008DFA798/ref=oh_details_o00_s00_i00?ie=UTF8&psc=1 04/14/2014 - Onkyo has agreed to a "one-time" repair even though the unit is out of warranty.
  • Read full review
Overall 2
2.0

Sound Went out

Derek, Amazon
3 weeks ago
  • Summary: When it worked it worked great now its no sound and onkyo customer service is terrible..It was an unknown Unknown Things that you don't know that you just don't know!
  • Read full review
Overall 2
2.0

No sound after 26 months!

Leann P Gage, Amazon
26 January 2014
Overall 2
2.0

I just joined the club

rikMan, Amazon
29 September 2013
  • Summary: 22 months in with quite a few intermittent HDMI "glitches". Now I have zero sound from any HDMI source. Powering off and waiting fixed it for a bit. Then I did a firmware upgrade and it was OK again for a week or so. Now I am back to being dead in the water. Factory resets, power offs, prayers...nothing works. ONKYO sucks.
  • Read full review
Overall 2
2.0

Amazing... until it stops working.

Albert Delre, Amazon
8 September 2013
  • Summary: This receiver worked perfectly for 20 months. Until suddenly it just stops working... It has power and the settings menu works. However, audio or video from any device is no longer working. I see a lot of negative reviews about them breaking down around the 18-24 month mark, and sadly its all true.
  • Read full review
Overall 2
2.0

After 17 months it just stopped sending video to the TV

Amazon Customer, Amazon
9 August 2013
  • Summary: I had been very happy with this product since the purchase back in March 2012. Now, 17 months later the unit just stopped sending video to the TV. If I leave it turned off for a day I can get video for about 3-4 hours but then it cuts out again. The unit gets extremely hot and I'm guessing that this has caused some components within the unit to fail. Sad, really, as I liked it. Reading online it appears that this is a common failure of this Onkyo AVR.
  • Read full review
Overall 2
2.0

DO NOT BUY.....RUN AWAY

ram, Amazon
26 May 2013
  • Summary: Hdmi board is a constant issue. Already sent receiver for repairs under the warranty. Cost over 60 for postage and insurance. After having it back for two months the hdmi board is acting up again. No one should have to go through this. U HAVE BEEN WARNED. DO NOT BUY! !!
  • Read full review
Overall 2
2.0

Lasted only a year...

Martin, Amazon
26 December 2012
  • Summary: My receiver that I purchased in November of 2011 just died. It lasted a year. Now I have to deal with shipping it to an authorized service center which is 160 miles away. It was nice when it worked, but I expected a longer life. Search for "TX-NR609 no video signal" and you'll find a bunch of topics of people with the same issue. You can hear audio, but can't see any video.
  • Read full review
Overall 2
2.0

Worked for 4 Months - HDMI Failure

TMK, Amazon
29 April 2012
  • Summary: I purchased an Okyno TX-NR609 from Amazon in early December based on the positive reviews received here as well as multiple other AV sites. I used it as the center of my media/entertainment hub -- replacing a several year old Okyno that only supported component video out. It worked well until about a week ago when I apparently suffered the same fate that many others have suffered with this unit -- a failure of the HDMI board -- rendering it effectively useless as a...
  • Read full review
Overall 2
2.0

HORRIBLE - Will Never buy Onkio again

Amazon Customer, Amazon
19 April 2012
  • Summary: A complete waist of time and money. After spending a few hours setting everything up just right we discovered that one of the channels is bad and always has static (even when the volume is at 0. ) We called Onkio and they said right away when we gave them the model number that they are aware of this problem and they will send us a return label (wait 7 to 10 days) we will ship the product (wait 7 to 10 days) they will repair it (wait 20 days) and then they will ship it...
  • Read full review
Next page >>