www.testfreaks.com

Reviews, reviews, reviews...

Denon-avr-3310.26105933
6.5 out of 10

Denon AVR-3310

120 watts per channel x 7 channels 8 ohms Dolby TrueHD, Dolb Read more

Best Price at Amazon

Reviews and Problems with Denon AVR-3310

Showing 1-4 of 4
Overall 2
2.0

Didn't last long, lacking customer service

Lionel D. Garcia, Amazon
29 November 2013
  • Summary: I purchased this amp in July of 2010. I didn't have the money for speakers so i hooked it up and was using it as a passthrough. i finally ordered a set of Definitive Technologies speakers, which by the way are fantastic. I installed the speakers and had a professional company do the hook - up and to my dismay the internet portion of the amp would not work. At the time the amp was about 2-3 months out of their two year warranty.
  • Read full review
Overall 2
2.0

Denon Quality Is Poor. Two Denon AVR-3310CI receivers failed.

R. Maben, Amazon
30 October 2011
  • Summary: This review is for the AVR-3310CI and probably the AVR-3311CI (per other reviews). I usually do not write reviews. However, after buying two of these AVR-3310CI receivers at different times (6/2010 & 11/2010) and having both fail I feel impelled to give my story. The first one failed twice so far. The networking card twice and then the video. This one is still in the shop and it has been there 3 weeks so far. The second one has just failed with it's network card.
  • Read full review
Overall 2
2.0

Don't Buy

jbm6900, Amazon
24 September 2010
  • Summary: Stay away from this unit! Problems began within 1st few weeks.It will be working fine, then it will jus quit & a pulsing sound will come from the speakers. it will only play again if i turn the unit off then back on again. I shipped it to Denon repair twice & problem still exists. They claim its the speakers or the "Environment"! Well, while the unit is in repair, My old Onkyo works just fine with the same speakers in the same "Environment".
  • Read full review
Overall 2
2.0

Only pure direct mode works fine...defective dsp simulation

Richard, Amazon
20 June 2010
  • Summary: 2nd Update...I'm getting closer to what really goes wrong. I have a HDMI out from 3310ci to a sharp LED TV. When I turned on the TV, or unplugged this HDMI cable, the receiver immediately went back to normal, problem gone. Everytime this HDMI connection is hooked up and TV is off, the problem occurs. I called Denon service, they suggested to turn off HDMI control on both receiver and TV, I did but problem stays. I'll probably call them again to fix.
  • Read full review